[Samba] Printer settings problem 2.2.6pre2

Philip T Burrow p.t.burrow at inghams-law.co.uk
Wed Sep 25 12:14:01 GMT 2002

I am trying to apply some settings to a printer shared by Samba, including 
installing the drivers. I notice that I must be in printer admin or be 
root in order to do this, and I am. The logs say that I'm 
"logged in as admin user (root privileges)" which I assume is correct.

I go into properties, click no when it asks me if I want to install 
drivers, and then go to New Driver and install one. The driver copies fine 
to the Samba server, but as soon as I click OK or Apply, I get "Printer 
settings could not be saved. Access is Denied."

Now, I'm running an LDAP server for a current working domain in which all 
printer stuff works without Access Denied errors, and I am using that 
server to serve all the user stuff to this 2.2.6 server. I am using the 
same smb.conf as well, apart from domain logons = no in the 2.2.6 one. I 
have tried deleting all the printer related tdb files and restarting Samba 
but I just get the same error.

My thought is that it's a simple file permission I've missed, because it 
uploads the drivers without a problem, but I can't 
seem to find it!

Anyone got any suggestions?


More information about the samba mailing list