[Samba] Read failure for 4. Error = connection reset by peer.

Bob Crandell bob at assuredcomp.com
Mon Sep 23 23:18:01 GMT 2002

I'll offer this without asking what your setup is.

In the Global section, add:
oplocks = no
level2 oplocks = no
kernel oplocks = no

Then killall -HUP smbd
Then killall -HUP nmbd
to force Samba to reread the config file.

If you already did this then others will have to help.  This fixed that problem
every time I ran into it.

Jason Valenzuela (jason.valenzuela at worldnet.att.net) wrote*:
>I am having a SERIOUS problem with our new 2.2.5 server. In fact I will
>probably be forced to move to a Windows 2000 Server platform, as the samba
>server is practically useless.  Work on any files on the share cannot be
>done without major risk of losing data. I get these two errors all day:
>[2002/09/19 21:04:21, 0] lib/util_sock.c:read_data(436)
>   read_data: read failure for 4. Error = Connection reset by peer
>[2002/09/20 00:58:43, 0] lib/util_sock.c:read_data(436)
>   read_data: read failure for 4. Error = Connection timed out
>Most of them are the connection reset by peer. I get more than 25 a day at
>times, at intervals ranging from 5 minutes to several hours. If someone has
>a file open during that time and try to save I get a bunch of oplock log
>errors, their application crashes and all data is lost. I've searched and
>searched w/ google, no one seems to have any solutions. I've tried some
>keepalive options. Both socket level and application level, both failed.
>Somone mentioned a registry fix but that also seems to have failed. My
>clients are mostly Windows 2k with a couple of XP's.
>Jason Valenzuela
Bob Crandell
Assured Computing
When you need to be sure.
Voice 541-689-9159
FAX   240-371-7237
bob at assuredcomp.com
Eugene, Or. 97402

More information about the samba mailing list