[Samba] Trouble with Windows 2000 sp3

Joshua Pollak jpollak at cra.com
Mon Sep 23 19:01:00 GMT 2002


I work in a development shop where we write code for both Linux and Windows, 
and develop on both OS's on a codebase stored on a Linux drive with Samba 
shares. Ever since I 'upgraded' my Windows 2000 system to service pack 3, I 
have been having trouble compiling my code with Visual Studio over this Samba 

Basically what happens is that Visual Studio reports "cannot open file" for 
various .exp, .sbr, .lib, or .dll files that it tries to write to during the 
compilation process. When I try to go into Windows Explorer and delete the 
file, I get an error message that another process is using the file. I can 
delete the file without a problem from my Linux machine, and then I can 
usually resume compilation on the Windows box, but this is very aggrivating 
as we have a large project.

Usually the only way to resolve this problem is to reboot the Windows machine, 
but some of Microsofts latest critical updates seem to have made THAT not 
even work.

Anyway, I have tried getting the Linux admin to disable oplocks, with this set 
of commands:

oplocks = no
locking = Yes
share modes = Yes

But that doesn't seem to have worked. What gives? Is there anything else I can 

Joshua Pollak
Software Engineer
Charles River Analytics

More information about the samba mailing list