[Samba] Access denied in bats with long path

Departamento Técnico tecnica at pulsoinformatica.es
Thu Sep 19 08:17:01 GMT 2002

I'm new in the list, and I'd like to post this problem. Sorry if it's an old
My server is SuSE Enterprise Server 7 running Samba 2.2.4-2. Samba works
fine, but I've this problem.

In a share carpet, with a long path (/u/aplic/utilidades in server,
L:\aplic\utilidades from the W98 point of view), I have several .bat.
If I run this .bat from a W2000 machine, all works fine. But if I run this
.bat from a W98 machine (first or second edition, no matter), I get an
"Access denied - L:\aplic\utili~-3\x.bat" message, where x is the name of
the .bat.
The bat is successfully executed, but the error cause an application hang,
so I have to solve this problem.
If I put these same .bat in other carpet with a short name (utils, for
instance), all works fine.

It seems a problem with W98 running .bat from a share with long path. This
error occurs only from Window explorer, in a DOS Windows works fine.

Why this message? Any idea?
Best regards,

More information about the samba mailing list