[Samba] How to bypass smbfs 2Gb limit without patching ?

Geoffrey Hurlus ghurlus at bda.fr
Mon Sep 16 13:15:00 GMT 2002

Hello everyone,

I would like to send a big tar file (eg: >2Gbytes) from my Linux samba
server to a win2K client without patching the kernel.

Samba server: I'm using Linux version 2.4.8-26mdk (Mandrake Linux 8.1
2.96-0.62mdk) with samba 2.2.5-2.
I'm using tar (GNU tar) 1.13.22 to make the tar file and the command "cp" to
copy this tar file to my win2k client. I've never tried smbtar.

smb.conf: I've enabled
	- socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
	- large readwrite = yes

Win2k client: It is not upgraded to Service Pack 2. It hasn't got disk
quotas set. It is formatted in FAT32. It has enough disk space =)

Problem: The file copy stops at about 2097 Mb !

A friend of mine tried to copy a file bigger than 2Gb (with dd if=/dev/null
of=/mnt/...) from his Linux version 2.4.18-10 (Red Hat Linux 7.3 2.96-110)
box, with samba-2.2.5-1, to the win2K client and he had the same problem.

I've heard that the culprit was smbfs because it doesn't support file bigger
than 2Gb. I know there are patchs to this issue, but is there any way to
solve this problem without patching the system ?

I've never tried to patch my system as it is in production thus I'd prefer a
smooth method.

I noticed that the copy of the files was taking a long time. I looked at the
size of packets with IPTraf and it showed very little packets tranfers. I
then used mcopy from the mtools and the size of the packets were much

Thanks all for your kindness and support.
malX 		mailto:gh at bda.fr

More information about the samba mailing list