[Samba] ''resource or device no longer available' error with large files

a lu lutzow_wi at yahoo.com
Thu Sep 12 05:00:00 GMT 2002


I have a base 10 hub, a SAMBA 2.2.6 server on a
p200mmx, and a win98se box.  Everything in
DIAGNOSTICS.txt checks out fine, and everything seems
to work ok until i try to send an iso image across. 
That is when smbd crashes (about halfway/300M), and
win gives the error 'cannot copy or replace
<filename>: the resource or device is no longer
available.  That is the exact error everytime (from

I have tried different files, a different win98se box,
a different base10 hub, and a different network card
on the linux box (via-rhine as opposed to natsemi),
because someone else using natsemi reported a similar
problem on a newsgroup.

I can ftp the file either way just fine every time and
it uses less CPU.  I do have debug level set to 10
though (i turned it up only to see if i could figure
things out, it didnt work before that either).  That
seems to slow the transfer further.

mandrake 9 SAMBA 2.2.6 binaries.

I tried adding these lines to smb.conf:

-- socket options = SO_KEEPALIVE TCP_NODELAY

-- os level = 65

The logfiles and smb.conf are available here:
http://gemmint10.bounceme.net/samba.html  (malibu and
crash are the 2 win98se boxen that i tried, and 200mmx
is the server.  These logs are for about 3 or 4
transfer attempts total: from crash first, then

If you need any other info, i guess just email me at
lutzow_wi at y a h oo.com  I don't even have email set
up on the server yet.  Don't h4x me either.  I have
been rooted once already =P

Thank you to all that tried to help on irc
openprojects #samba (mishimu).


Do you Yahoo!?
Yahoo! News - Today's headlines

More information about the samba mailing list