[Samba] rename not working while all other things work?

Thomas Seifert ts77 at dasburo.de
Wed Sep 11 15:28:00 GMT 2002

Hi folks,

I've got a serious problem with samba since I upgrade an stone-age caldera-box with a 2.0.x-samba to redhat-7.2 with 2.2.1a-samba.

I can create, delete directories and files without any problems. But renaming them (i.e. by creating a new folder which has new folder as default) does not work.
I always get an error, that the file does not exist. I am trying from a win2k-professional box but I had reports of that problem with nt-4 too.

Any ideas what could generate this problem?

my stripped-down smb.conf looks like that (I tried to generate it with SWAT in case I had a typo anywhere):

        workgroup = WORKGROUP
        server string = Amiga 5000 Samba Server
        log file = /var/log/samba/smbd.log
        max log size = 50
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        dns proxy = No
        kernel oplocks = No
        hosts allow = 192.168.1. 192.168.5.

        comment = Home Directories
        read only = No


I have already tried 2.2.5 ... didn't help with this problem too.

I would be glad for every help I could get to resolve this.

Oh and btw. the files or directories I tried all have rwx rights, the parent dir too.

Thanks in advance


More information about the samba mailing list