[Samba] Samba mounting problems.

John W Cunningham John at pickaprof.com
Wed Sep 4 02:54:01 GMT 2002

Howdy all -->

I am having major issues mounting smb file systems on my Linux (RH 7.3)

Basically, I create a folder, either in a home directory or at the root,
change it's permissions to the user to make it accessible to me outside
or root, and run this command as root (not accepted as a user):

mount -t smbfs -w -o rw -o user -o password= // /mp3

I'm behind a firewall so internal security is lax, and right now I'm
just trying to get it to work.  Basically (as I read it): File system
type smbfs, write permissions, read / write permissions, user can mount,
password is blank (this avoids the system asking for a password), point
to the /mp3 folder on the smb server, and mount to /mp3 (same result
when I mount to a folder in a user's home directory)

This command works - but changes the ownership of that directory to
root/root, and the user can't edit or save anything.

I'm really going nuts here because *I watched it work once* - then the
second time I tried it no dice.  Any ideas?  I need this to be editable
by a user, and to know where to put the mount command so it's automatic
on boot.

Thanks in advance-->

More information about the samba mailing list