[Samba] PDC connect problem

Jacob Smith jacob at globalsat.com
Thu Oct 31 19:50:02 GMT 2002

This is all you should need for a bare minimum PDC to work.

domain logons = yes
domain master = yes
security = user
workgroup = YOURDOMAIN
encrypt passwords = yes

writeable = no
guest ok = no

Make sure netlogon directory exists and then run the tesparm utility with
this config.

-----Original Message-----
From: samba-admin at lists.samba.org [mailto:samba-admin at lists.samba.org]On
Behalf Of Richard Fox
Sent: Thursday, October 31, 2002 2:14 PM
To: samba at lists.samba.org
Subject: Re: [Samba] PDC connect problem

> If this is a multi-homed machine then you might try

> interfaces = xxx.xxx.xxx.xxx
> bind interfaces only = yes

I tried this an it had no effect on the problem, which is that the domain
controller for this domain cannot be located. In order to eliminate any
possible problem of multiple networks I deleted the other network device,
eth1, which was inactive anyway, from my PDC machine. Also all other hosts
on the 192.168.0. network have been removed from my /etc/hosts file. Now I
just have eth0 set to and localhost, thor (RH 7.3 PDC) , and
mercury (NT) in my /etc/hosts.

I also tried
      wins support = yes

and this also had no effect.

I do believe, from what I have read, that I have a minimal smb.conf file for
a PDC.  Here it is again:

        workgroup = MYGROUP
        netbios name = THOR
        os level = 64
        domain master = yes
        preferred master = yes
        local master = yes
        security = user
        encrypt passwords = yes
        domain logons = yes
        logon path = \\%L\Profiles\%u
        logon drive = H:
        logon home = \\%L\%u
        logon script = netlogon.bat
        comment = Home Directories
        path = %H
        writeable = Yes
        valid users = %S
        create mode = 0664
        directory mode = 0775
        comment = Network Logon Services
        path = /home/samba/netlogon
        read only = yes
       # list of all possible users who I could imagine would try to connect
during testing.
       # All have samba passwords = Unix passwords (or NT in case of
        write list = Administrator, rfox, root
        path = /home/samba/profiles
        browseable = No

I am very surprised that the log file shows no attempt to connect when I try
to join the domain MYGROUP from mercury. The log file does show that samba
initialized ok and is waiting for connections.

I don't know how to simplify things any further. My network is 2 machines
only, no additional interfaces. I did remove the DNS server IPs and gateway
IP from mercury's TCP/IP settings but this also made no difference so I put
them back.

Keep these ideas coming, I am completely stumped.

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list