[Samba] smbmount share into root filesystem/permissions error

Barry Smoke barry at arhosting.com
Thu Oct 31 19:33:01 GMT 2002

This is a samba/smbmount/ltsp question/problem...and it is kind of
detailed....I tried to simplify as much as possible...:
if anyone can help, we would be grateful!

We have a share, that contains our alsdata for Accelerated Reader(AR). 
This is working great for Accelerated Reader, and has been for 1 year
now.  We force the alsdata share to have these permissions in the
smb.conf file:
        path = /raid/bes/apps/alsdata
        admin users = @tech @library
        valid users = @tech @bes @library
        force group = bes
        force user = bes
        force create mode = 0777
        force directory mode = 0777
        comment = Renaissance Learning Data Folder
        write list = @bes
        browseable = yes
        oplocks = yes
        blocking locks = yes
        level2 oplocks = no
        fake oplocks = no
        oplock contention limit = 150
        veto oplock files
         vfs object = /usr/lib/samba/vfs/recycle.so
        vfs options = /etc/samba/recycle.conf

so we force the alsdata share to be wide open, which is what AR needs it
to be, and this is also the case with novell, etc...

now to what is not working...

We have started experimenting with AR, and codeweavers crossover office:
so, now that AR installs correctly onto a linux box with crossover
office installed, we now have the need to mount this alsdata share into
the root filesystem.  

We are using "mount -t smbfs -o
username=bes,password=******,dmask=0777,fmask=0777 //samba/alsdata

we also tried setting a uid, and gid to bes, and the same results below:

what happens on our ltsp box, is that when you log on to a ltsp session
as root, and run AR in a wine session(crossover office installed)
the AR program works correctly...


when you log on as any other user added to the ltsp server, 
there is a database error in AR....which we have seen before, and was a
permissions based error....why would it work for root on ltsp, and not
for any other user

More information about the samba mailing list