[Samba] Winbindd not listing users/groups

Sean Patrick Ingles ingless at visionsys.com
Thu Oct 31 15:13:01 GMT 2002

As requested:
Here is my smb.conf (I have it stripped down to eliminate anything else,
once I get winbindd working I plan on defining shares, etc):
Also I noticed that occasionally _something_ happens and I cannot login
to the linux box at all when winbindd has been running, I have to hit
the reset button.
         workgroup = DOMAIN
         server string = Samba %v -- TEST --
         security = domain
         password server = Windows2kDomainController
         winbind uid = 10000-20000
         winbind gid = 10000-20000
         winbind separator = +
         winbind cache time = 10
         winbind enum users = Yes
         winbind enum groups = Yes
         password server = *
Also here is my /etc/pam.d/authconfig
auth       sufficient   /lib/security/pam_rootok.so
auth       sufficient   /lib/security/pam_winbind.so
auth       required     /lib/security/pam_pwdb.so use_first_pass shadow
#auth       required    /lib/security/pam_stack.so service=system-auth
account    required   /lib/security/pam_winbind.so
#account    required    /lib/security/pam_permit.so
session    optional     /lib/security/pam_xauth.so
session    required     /lib/security/pam_permit.so
Let me know of you need anything further!
-----Original Message-----
From: Jennifer Fountain [mailto:JFountain at rbinc.com] 
Sent: Thursday, October 31, 2002 9:56 AM
To: Sean Patrick Ingles; samba at samba.org
Subject: RE: [Samba] Winbindd not listing users/groups
Can you send me (the list) your smb.conf file?
	-----Original Message-----
	From: Sean Patrick Ingles [mailto:ingless at visionsys.com]
	Sent: Thursday, October 31, 2002 9:43 AM
	To: samba at samba.org
	Subject: [Samba] Winbindd not listing users/groups
	Greetings from NY!
	I am running SaMBa version 2.2.6 compiled from source on a
RedHat 7.3 (Linux tux.#########.net 2.4.19 #1 Fri Oct 25 15:39:52 EDT
2002 i686 unknown) box.
	I start smbd and nmbd as I usually do.
	Then I start winbindd
	I verified that they are running.
	I run :
	smbpasswd -j DOMAIN -r Windows2kDomainController -U
	Joined domain DOMAIN.
	Ok, so I'm in the domain
	Then I run:
	[root at tux src]# wbinfo -t
	Secret is good
	Even better, my secret is good!
	Then I try and list users/groups:
	[root at tux src]# wbinfo -u
	Error looking up domain users
	[root at tux src]# wbinfo -g
	Error looking up domain groups
	And I sit there starting blankly at the screen, searching
google, etc, then I join the SaMBa mailing list and cross my fingers
that there is someone out there who can help!
	I'm trying to integrate this Linux/SaMBa server into my
Microsoft-only Company, and so far the powers that be are up to it, but
I want to show them that the Linux fileserver can authenticate against
their current Windows 2000 Server domain controllers so we don't need 2
separate user databases.
	Any assistance is much appreciated!
	   \        /   ____/    / Sean Patrick Ingles
	    \      /   /        / Jr. Network Engineer
	     \    /   ___ /    / 
	      \  /       /    / Vision Systems, Inc.
	      __/   ____/   _/ 142 State Street
	                       Albany, NY 12207
	    www.visionsys.com <http://www.visionsys.com>    Landline: +1
518.434.4300 x1406
	  ingless at visionsys.com <mailto:ingless at visionsys.com>   Fax: +1
-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list