[Samba] File locking problems - v2.2.6

Paul Sergeant pfs at mercuryint.co.uk
Wed Oct 30 11:45:01 GMT 2002

It may not be a samba problem.

We had 2.0.5 running on Red Hat 6.X , and a dos based app
(written in Alpha) installed on PC's running 95/98, no locking

Upgraded to Red Hat 7.2 and Samba 2.2.3 , everything worked except
the dos app. Locking problem between two workstations.

Installed 2.0.5 on a SCO unix 5.0.5 system and still had the locking

Built new box using old version of Red Hat (6.x) and Samba(2.0.3) no
locking problem.

So we now have two samba servers, one running OLD version and one running
newer verions.

Paul Sergeant.

-----Original Message-----
From: samba-admin at lists.samba.org [mailto:samba-admin at lists.samba.org]On
Behalf Of Brian W Spoor
Sent: 30 October 2002 11:07
To: samba at samba.org
Subject: [Samba] File locking problems - v2.2.6


I have been going crazy over the last few weeks trying to install a new
Samba server (using v2.2.1, v2.2.5 and v2.2.6) to replace a old system.
Problem seems to be with file locking on the new server - works
perfectly on old server!!

Attached are configuration files for Samba for old (smb205.conf) and new
(smb226.conf) servers, plus the source of a Cobol test program
(samtest.cbl) that demonstrates the problem. Also included is a program
(samdata.cbl) that creates the test file. I can supply binary versions
if required - not sending .EXE for anti-virus purposes.

I have tried various variations on the parameters, but doesn't seem to
make a lot of difference. Am I missing something?

Old Server - FreeBSD 3.2 + Samba 2.0.5 - P2/300 with 128Mb RAM

New Server - RedHat Linux 7.2 + Samba 2.2.6 - Duron 1200 with 768Mb RAM

Workstations - MS-DOS 6.22 + MS-Client v3.0 - P200MMX/P233MMX with 64Mb

Problem: simulating multi-user access to a file, when program hits a
locked record (cobol reply 9/68 - record locked) both machines freeze
for some considerable time (15 - 30 mins) before they continue. Program
reply test has a delay loop built in such that it will wait before
re-trying the locked record (have tried making delay 10 times longer to
no effect). Also under 2.2.1, it seems that one workstation runs for
several seconds, locking the other out. They them swap. Doesn't seem as
bad under 2.2.5, but still happens to some extent depending on the

  From the release notes, I had hoped that 2.2.6 cures this problem. Am I
missing something?



Brian W Spoor MBCS
Chartered Information Systems Practitioner

Phone: +44-(0)1803 852625
Email: bwspoor at fcs.eu.com

 This email has been virus checked by the Eclipse Internet MAILsafe service
 www: http://www.eclipse.net.uk/                email:
eclipse at eclipse.net.uk

More information about the samba mailing list