[Samba] Two nmbd processes on 2.2.6

Noel Kelly nkelly at citrusnetworks.net
Fri Oct 18 17:46:00 GMT 2002


I have downloaded and compiled 2.2.6 to replace my 2.2.6pre.

I spent a large part of the day debugging the startup script because it
seemed to always be starting two nmbd processes instead of one.

Eventually I tried running just /usr/local/samba/bin/nmbd - and still got
two nmbd processes.  Is this correct behaviour?

On the first server (Dell 4600) I thought it might be because it has one of
the new hyperthreading BIOS which makes Linux believe it has dual
processors.  The machine also had two NICs - one for each card?

However, I tried in on my old PII 233 single processor and single NIC and
sure enough two nmbds get started.

Have I missed something?  Are there supposed to be two running these days?
I simply compiled with the usual parameters (./configure --with-smbmount
--with-utmp --with-msdfs --with-automount) and have made sure only one nmbd
exists on the system.

Any ideas anyone?


Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.394 / Virus Database: 224 - Release Date: 03/10/2002

More information about the samba mailing list