[Samba] Still can't make it work (LONG)

DJ Busch djbusch at new.rr.com
Thu Oct 17 03:30:01 GMT 2002

Well gang, I'm back and still haven't figured out why Samba isn't working with my Windoze PC's.  I though I was close a couple times, but now I'm back to square 1.  So now I'm going to spill as much information on you guys as I can in the hope that someone will notice what I'm doing wrong and help me get this thing running.

Here are the computers on my home network:
A.	Linux Box (luke) - AMD Athlon 750 MHz, 256 MB RAM, (2) 20 GB IDE HD's
	RedHat 7.3 (kernel 2.4.18-3)
	Samba v2.2.6pre2-1
	3Com 3C509 PCI TPO Ethernet Adapter
	IP set by DHCP from ISP (Time Warner/RoadRunner)

	This machine also boots Windows 2000 Professional and can browse other
	Windows shares when using Windows 2000.

	smb.conf file for this machine is attached.  I've scaled it down to make it 
	easier/faster to read.

	This box has both ipchains and iptables installed.  I'm not sure if these 
	can cause the problems I'm having or not.

B.	Windoze Box #1 (jarjar) - Toshiba Satellite Laptop, Pentium III 750 MHz
	Windows 98 SE
	Netlink PCMCIA Ethernet Card
	IP set by DHCP from ISP

C.	Windoze Box #2 (obi-wan) - 486 DX2 66Mhz, 8 MB RAM, 400 MB HD
	WFW 3.11
	3Com 3C509 ISA Ethernet Card

I tried running through the DIAGNOSIS.txt file with the following results:

Test 1:  testparm shows all clear
Test 2:  (from obi-wan) ping luke: Success (had to manually supply IP address)
	   (from luke) ping obi-wan: Success (had to manually supply IP address)
Test 3:  smbclient -L luke: Success (asks for password but accepts blank)
Test 4:  nmblookup -B LUKE __SAMBA__:  Success
Test 5:  nmblookup -B JARJAR '*' : Failed (name_query failed to find name *)
	   nmblookup -B OBI-WAN '*': Failed (name_query failed to find name *)
	   Tried this one with ipchains/iptables and without - same result both times
Test 6:  nmblookup -d 2 '*' : Returns only the IP of the Linux box.
Test 7:  smbclient //luke/homes : Success
Test 8:  (from obi-wan) net view \\luke: Failed (couldn't find computer name on network)

I've tried to telnet from one machine to the other on port 139, and each attempt fails.  However, when I try to telnet into a machine from itself, it works....from each machine.  
This has led me to believe that there is a problem in the network at the hub level...but what could that be?  Both Windoze machines are able to share and browse at will.  If the Win machines can't connect to each other on port 139, how are they sharing? 

I hope someone on the list can help.  This has been a problem long enough now.

Thanks in advance,

DJ Busch

More information about the samba mailing list