[Samba] Memory Leak in 2.2.6rc2??

Gerald (Jerry) Carter jerry at samba.org
Mon Oct 14 01:15:01 GMT 2002

On Sun, 13 Oct 2002 gsmith at ahbl.ca wrote:

> What I ran into was:
>  - getent would show only local groups

What about domain users ?

>  - Win2k workstations connecting would only come in as nobody
>  - shares would show up but double-clicking on a share would result in a
> login dialog. 
> I started with pre2 and worked up to rc3.  At some point things went really
> haywire and I got the looping getent you describe.

Could you grab logs for any of thse failures?

> The domain is mixed mode.

Just to clarify, this is the RedHat 2.2.6[pre|rc]X rpms from samba.org 

> the one thing I do notice is a noticeable pause when loggin in or for
> any process requiring authentication (e.g. scp)

This could be solved by setting "winbind enum [user|group]" to no.  I get 
looping in "getent group" regardless.

> 	winbind use default domain = Yes

This should be disabled.  Not a very well tested option.

Everything else your smb.conf looks in fair order.

cheers, jerry

More information about the samba mailing list