[Samba] Samba CVS

James Brechtel jbrechtel at harrison.k12.ms.us
Fri Oct 11 12:25:59 GMT 2002

Ok, I've compiled samba from cvs and have it installed and running fine.  I'm 
trying to get winbindd setup so I can log in using windows login accounts.  
Now, my machine is joined to the domain properly (wbinfo can -a authenticate 
names and password...  secret check succeeded... wbinfo -u wbinfo -g 
works...getent passwd and getent group both work fine..).  /etc/nsswitch conf 
has lines

passwd:     files winbind nisplus nis
shadow:     files nisplus nis
group:      files winbind nisplus nis

/etc/pam.d/login has

auth       required	/lib/security/pam_securetty.so
auth       required	/lib/security/pam_winbind.so
auth       required	/lib/security/pam_stack.so service=system-auth
auth       required	/lib/security/pam_nologin.so
account    sufficient   /lib/security/pam_winbind.so
account    required	/lib/security/pam_stack.so service=system-auth
password   required	/lib/security/pam_stack.so service=system-auth
session    required	/lib/security/pam_stack.so service=system-auth
session    optional	/lib/security/pam_console.so


Now when all the samba daemons (smbd, nmbd and winbindd) are running...login 
doesn't work at all.  I can su (to root or local accounts) from existing 
terminals but logging in from vty doesn't work at all (using local or windows 
accounts).  Su'ing to a windows account doesn't work however.

I ran winbindd in debug and watched it whenever I tried to su to a windows 
account...and it doesn't say the password was wrong...but it doesn't say it 
was successful either (like it does when I authenticate with wbinfo -a).    

Anyone have any idea or is this just how the current cvs code acts?

Thanks in advance,

James Brechtel
Programmer, Harrison County Schools

More information about the samba mailing list