[Samba] tail -f & the missing data:2.2.5, 2.2.19-6.2.16,

Sean Cullen Sean.Cullen at voxpilot.com
Wed Oct 9 17:34:01 GMT 2002


I have a strange problem viewing data in real
time. I wonder can anyone help?

I run tail -f on a file which is served by
a windows 2000 machine. I start a simple
program running on windows 2000 which writes
numbered lines of text to this file. I
notice that tail -f is missing some of
the lines. If I edit the file afterwards
the data is there it's just that tail
seems to miss bits of it when viewing it 
in real time.

Redhat 6.2 2.2.19-6.2.16
Samba 2.2.5
Windows 2000

[reproduce by]
cd /share/mount/point
touch sean.txt
tail -f sean.txt | tee /tmp/sean-tail.txt

start program on windows 2000

I stop the Windows 2000 process.

I compare sean.txt and /tmp/sean-tail.txt
and they are different.

[already tried]
upgrading to latest RH kernel and samba stable.
handwritten tool to ensure tail was not acting crazy.

Can anyone help me with this?

I noticed some other reports of problems
with tail -f in the archive, but they
appear to be a different problem.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: different-content.zip
Type: application/x-zip-compressed
Size: 1238 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20021009/f30a497c/different-content.bin

More information about the samba mailing list