[Samba] protocol error with OpenLDAP, v3

Malte Müller mamue at lb-bbs1.emd.ni.schule.de
Tue Oct 8 15:19:01 GMT 2002

I sort of succesfully installed samba2.2.5 with OpenLDAP 2.0.26 as a PDC on one
Alas the performance is very poor. Authentication process takes 10 Seconds pser, noticable one or two seconds per "net use d:" in the logon script.
The process which consumes all CPU cycles is slap. I tried to tune with some h
help of openLDAP mailinglist members (indices, nscd), but i didn't solve the
Now I try to set up a second machine with SuSE 8.1 with OpenLDAP 2.1.x and 
Samba 2.2.6pre2. It compiles and links fine, but when I try to log in
it says:
passdb/pdb_ldap.c: ldap_open_connection(216) connection opened
passdb/pdb_ldap.c: ldap_connect_system(246)  Bind failed: protocol error

I can search the ldap-database and authenticate against it from command-line
i.e. ldasearch -w -W uid=administrator.
I assume that samba can not handle ldap v3?
Has anybody an idea why login(script) is that slow? The original machine is a
PIII, 1GHz, 1GB RAM with SuSE8.0
I do some conf inclusion depending on %G and %U. Further I have a user base of
4500 pieces ;-) and groups with 12k Entries, the largest 4500. I tried to 
execute every SRCH statement solely but it was reasonable fast (<0.5 Sek each).

It is a real show stopper for me.
Any helping comment is welcomed.

Malte Mueller

More information about the samba mailing list