[Samba] XP Pro and Samba 3.0-alpha1.9

Irving Carrion debian at allinterior.com
Wed Oct 2 13:16:00 GMT 2002

Not in my case.  The "add user script" worked in the previous version
but when I upgraded from Samba 2.2.3a to the latest CVS version it no
longer worked.  The way I got it working was to use the "add machine
script".  Now it works just fine.  Anyway, try them both -n- see what ya


-----Original Message-----
From: Kalkoul Morad [mailto:M-Kalkoul at arte-tv.com] 
Sent: Wednesday, October 02, 2002 3:04 AM
To: 'Irving Carrion'; Kalkoul Morad; samba at lists.samba.org
Subject: RE: [Samba] XP Pro and Samba 3.0-alpha1.9

I believed this was enough to add a machine:

add user script = /usr/sbin/useradd -d /dev/null -g 502 -s
/bin/false -M %u 

in my smb.conf

-----Message d'origine-----
De : Irving Carrion [mailto:debian at allinterior.com]
Envoyé : mardi 1 octobre 2002 19:52
À : 'Kalkoul Morad'; samba at lists.samba.org
Objet : RE: [Samba] XP Pro and Samba 3.0-alpha1.9

I think you need to add the "add machine script" command in your
smb.conf.  check man smb.conf for more info.

Hope this helps.

-----Original Message-----
From: samba-admin at lists.samba.org [mailto:samba-admin at lists.samba.org]
On Behalf Of Kalkoul Morad
Sent: Tuesday, October 01, 2002 12:37 PM
To: samba at lists.samba.org
Subject: [Samba] XP Pro and Samba 3.0-alpha1.9

Hi everybody,

I set up Samba 3.0alpha1.9 on a RH7.2 and I want  to configure it as a
Primary Domain Controller.
Below , my smb.conf:
# Samba config file created using SWAT
# from (
# Date: 2002/10/01 09:04:58

# Global parameters
	;Nom du domaine
	workgroup = MOMODOM

	;Nom netBios de la machine
	netbios name = SRV2000

	;Commentaires qui sera affiche dans le vouisinage réseau
	server string = Samba Server Beta Test 3.0

	encrypt passwords = Yes

	password server = bin/passwd

	passwd program = /usr/bin/passwd  %u

	unix password sync = No

	log file = /var/log/samba/SMB%m.log

	max log size = 0

	socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

	domain admin group = root at SRV2000

;	add user script = /usr/sbin/useradd -d /dev/null -g 502 -s
/bin/false -M %u

	logon script = logon.cmd
	logon path = \\%N\%u\profiles

	logon drive = H:

	logon home = \\SRV\%U

	domain logons = Yes

	domain admin group = @admin

	os level = 64

	preferred master = True

	domain master = True

	dns proxy = No

	wins server =

	default service = export\samba\test

	printing = lprng

	comment = Home Directories
	valid users = %S
	read only = No
	create mask = 0664
	directory mask = 0775
	browseable = No
	writable = Yes

	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	browseable = No

	comment = Partage de test
	path = /tmp
	guest ok = Yes
	browsable = Yes
	writeable = Yes

	comment = Network Logon Services
	path = /home/netlogon
	writeable = no
	browseable = no
	write list = root

And I create a Machine Trust Account, like this;
#useradd -g admin -d /dev/null -c "Samba Test Machine" -s /bin/false
#passwd -l SRV2000$
#smbpasswd -a -m SRV2000$ (I found some docs with $ to put here and
without, What do I put????)

For me, my Machine trust account is OK.
To create a samba manager 
#smbpasswd -a root
and I use it to join the domain.

But when I try to join the Domain MOMODOM , it is refused because "user
unknown  or incorrect password"
And in the samba log file :
get_md4pw: Workstation SRV2000$: no account in domain

Someone has an Idea?

Thanks in advance, Mo

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list