[Samba] I will pay you $10US (via Paypal) out of my own pocke t if you can solve this CUPS & Samba problem.

WEBSTER, Greg GWEBSTER at ahbl.ca
Fri May 31 11:56:02 GMT 2002

[root at waifer root]# cupsaddsmb -a
Warning: No PPD file for printer "PSYSTEMS"!

What I'm guessing at this point is that Cups is having a hell of a time
reaching the PPD files. There definitely is one for my printer (HP 5000) on
the system.

Thanks, but no cigar :)


> -----Original Message-----
> From: Jason Stewart [mailto:jstewart at rtl.org]
> Sent: May 31, 2002 11:43 AM
> To: WEBSTER, Greg
> Subject: Re: [Samba] I will pay you $10US (via Paypal) out of my own
> pocket if you can solve this CUPS & Samba problem.
> try cupsaddsmb -a. If not successful, you will get an error. I had a 
> difficult time getting this to work also, so I definitely 
> sympathize with you!
> The cupsaddsmb drivers worked for me, but the downside is 
> that you will not 
> get the duplexing and other features that the manufacturer 
> supports. For 
> the usage instructions for cupsaddsmb, see the cups docs.
> Good Luck,
> Jason
> At 11:26 AM 5/31/2002 -0700, you wrote:
> >Seriously. I can't afford to be down much longer or I'm 
> going to be in 
> >serious trouble.
> >
> >Running Redhat 7.2.
> >
> >Here's the scoop:
> >Cups is installed and running.
> >Samba is installed and running and is sharing files properly 
> to 100+ people.
> >I can print a test page from the Cups web-interface.
> >I can print a test page by "cat foo | lpr" or "cat foo | 
> lpr.cups" no problem.
> >Swat sees the printer that exists in /etc/printcap.
> >A print$ share has been created:
> >     [print$]
> >         path = /usr/share/cups/model/
> >         guest ok = Yes
> >/usr/share/cups/model/ contains a bunch of PPD printer 
> drivers inside a 
> >directory called foomatic, created by a cups-drivers rpm. I 
> have also 
> >tried having the drivers I need directly in the 
> /usr/share/cups/model 
> >directory with no success.
> >
> >...when I am on a windows box and try to install the printer that is 
> >listed (via the Printers control panel or by browsing to the 
> Printers 
> >share via Network Neighbourhood), I get a "The server on 
> which the printer 
> >resides does not have the correct printer driver installed. 
> If you want to 
> >install the driver on your local computer, click OK".
> >
> >I really need to get this up and running. Please help.
> >
> >Greg Webster
> Jason Stewart
> Systems Administrator/Programmer
> Right to Life of Michigan
> Tel: (616)532-2300
> Fax: (616)532-3461
> To find out where Michigan Gubernatorial Candidate Jennifer 
> Granholm really 
> stands, please visit http://www.granholmgarble.com/

More information about the samba mailing list