[Samba] add user script w/ idealx perl script (ldap)

Yannick Tousignant ytousignant at oka-info.com
Fri May 24 10:37:02 GMT 2002

Dear samba guru,

I have a little bug i can't solve. It is pretty misterious to me,
must be a problem how samba execute the add user script. Now here
is the situation. I've compiled samba 2.2.4 with ldap 2.0.23 to run
as PDC with win2k workstations. Everything works as expected except
the add user script to add workstation automaticly to the domain.

add user script = /usr/local/sbin/smbldap-useradd.pl -w %u

This script is working fine when i run it in command line. But
when it's executed by samba when trying to join the domain, it
fails in a weird way. Here is the log :

[2002/05/16 14:34:34, 0] passdb/pdb_ldap.c:pdb_getsampwnam(777)
  LDAP search "(&(uid=yannick-2k_)(objectclass=sambaAccount))" returned 0
[2002/05/16 14:34:34, 0] rpc_server/srv_netlog_nt.c:get_md4pw(176)
  get_md4pw: Workstation yannick-2k$: no account in domain
[2002/05/16 14:45:48, 0] passdb/pdb_ldap.c:pdb_getsampwnam(777)
  LDAP search "(&(uid=yannick-2k_)(objectclass=sambaAccount))" returned 0
[2002/05/16 14:45:49, 0]
  User yannick-2k$ does not exist in system password file (usually
/etc/passwd). Cannot add account without a valid local system user.

I also tried the unix passwd sync parameters, and got some other problems
that are unresolved since i posted them a couple days ago.
(Samba+PDC+LDAP (add user script + unix passwd sync) Can't call perl script)

There is just something i don't get (how samba are executing the scripts
since they are working in command line!).

A little hand would be appreaciated!


Yannick Tousignant
Network Administrator
OKA Computer Systems ltd.

More information about the samba mailing list