[Samba] Can't print duplex -- getting worse

Gary Algier gaa at ulticom.com
Fri May 24 06:33:03 GMT 2002

The inability to print duplex is not fixed in 2.2.4.  On top of that,
I now have people that can't print at all.

A little background:
A while back (with 2.2.3, then 2.2.3a, then with several CVS snapshots)
I had the problem that even though I set the properties of a printer to
"Duplexer Installed", when a user tried to print two-sided, the option
did not show in the layout tab.

Well, I upgraded to 2.2.4 and this did not seem to fix anything, so I
deleted all the files in the locks directory and printers directory
and reinstalled all the printers to the samba server.  Still no joy.

Worse, I now have reports from the user community:
	1) Some people can't print. (I don't know the error, sorry.)
	2) Nobody can look at the properties of the printers.
	   The monochome PS printers.  No problems getting the
	   properties of the color PS printers.  (Printers share
	   driver code, don't they?)  The error is:
		Printer properties could not be displayed.
		Operation cound not be completed.
	3) Some people can't delete the printers from their own
	   PCs.  Even people with admin rights.

So, I figured something was wrong with 2.2.4 so I reinstalled the previous
CVS snapshot (I still have the binaries).  Same problems.  So, I then
deleted all the samba files and restored from backups.  Same problem.

It looks like some change in 2.2.4 changed the _clients_ and now
I can't get out of this mess I'm in.  I have people who can't print.

Lest anyone ask: the clients are all running win2k SP2.  Samba is running on
Solaris 8. Here is the smb.conf (I made no changes between 2.2.3a and 2.2.4):

         workgroup = MTLAUREL
         netbios name = PRINT
         server string = PRINT [Print Server on Chuckie]
         encrypt passwords = Yes
         show add printer wizard = No
         preferred master = False
         local master = No
         domain master = False
         wins server = mtlpdc
         ldap server = ldap.ulticom.com
         ldap port = 389
         ldap suffix = dc=ulticom,dc=com
         ldap admin dn = uid=sambaAdmin,ou=Directory Administrators,dc=ulticom,dc=com
         ldap ssl = no
         utmp = Yes
         guest account = ftp
         printer admin = @it

         path = /var/samba/printers
         write list = @it
         printer admin = @it
         create mask = 0774
         force create mode = 0770
         directory mask = 0775
         force directory mode = 0770
         guest ok = Yes

         path = /var/spool/samba
         printable = Yes
         browseable = No

         comment = Location for IT to download latest print drivers
         path = /var/samba/drivers
         write list = @it
         create mask = 0774
         force create mode = 0660
         directory mask = 0775
         force directory mode = 0770

Gary Algier, WB2FWZ          gaa at ulticom.com             +1 856 787 2758
Ulticom Inc., 1020 Briggs Rd, Mt. Laurel, NJ 08054      Fax:+1 856 866 2033

More information about the samba mailing list