[Samba] Can't access FreeBSD hosted Samba Shares

Randy Grafton rgrafton at indatacorp.com
Wed May 22 17:55:03 GMT 2002

Hi All,

I have installed the FreeBSD package of Samba, (samba-2.2.4_1.tgz) on a
FreeBSD 4.5 server.
My smb.conf is as follows:

netbios name=testBSD
server string=Samba Server
encrypt passwords=yes
password server=PDC BDC
os level=2

comment=Production Files

A system account has been created for this box through Server Manager on NT
and I ran
smbpasswd -j DOMAIN -r DOMAIN_PDC successfully.

The BSD box is displayed in My Network Places on Win2K and when I double
click on it the share
defined in the smb.conf file is displayed. My problem is that when I double
click on the share
I get the Window's message:
"\\TESTBSD\data is not accessible.
The network name cannot be found."

A new entry for each of these failed attempts shows up in my log file for
the smbd which states:
[2002/05/22 17:32:46, 0] smbd/service.c:make_connection(614)
  rgrafton ( Can't change directory to data (No such file or

This problem occurs regardless of the steps I use on the Win2k system to
access the share. i.e. Map Network Drive,
net use, start-run-\\testbsd, and start-run-\\(testbsd's ip address).

The /data directory on the FreeBSD server has 777 permissions assigned to

I also noticed that after a couple of tries that several entries of the smbd
show up when I run ps ax.

Any help is very much appreciated.

-Randy Grafton

More information about the samba mailing list