[Samba] Configuration Issues

Jay Aminu aminu1 at optonline.net
Tue May 21 12:51:02 GMT 2002

Hi Folks,

I am a Samba newbie and needed some assistance with my configuration.

I am trying to run Samba 2.2.2 (on Solaris 8 Intel Version) downloaded from
Sunfreeware.com and have a Windows 2000 Professional box.

I believed I followed the directions in SAMBA-How-To carefully but cannot
get connection from a DOS prompt.  When I run the command below from my UNIX
box, here is what I get:  The hostname on the Unix box is Abeokuta and the
Windows 2000 box is referred to as kdua.  I have an account on kdua - (IP
address known as kdua and the same on the Unix box - (IP address

When I launched the command below on the Unix box named "Abeokuta" - I get
the following:

[kdua at Abeokuta]# smbclient -L kdua
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
added interface ip= bcast= nmask=
Domain=[WORKGROUP] OS=[Windows 5.0] Server=[Windows 2000 LAN Manager]

        Sharename      Type      Comment
        ---------      ----      -------
        IPC$           IPC       Remote IPC
        D$             Disk      Default share
        Kdua_Share     Disk
        ADMIN$         Disk      Remote Admin
        C$             Disk      Default share

        Server               Comment
        ---------            -------

        Workgroup            Master
        ---------            -------
        WORKGROUP            LAGOS

When I tried to log onto the UNIX box from the DOS prompt on Windows 2000, I
get the following error messages:

c:\>net view \\Abeokuta
System error 5 has occurred.

Access is denied.

C:\>net use x: \\Abeokuta\kdua
System error 1240 has occurred.

The account is not authorized to log in from this station.

Please note that I am logged onto the Windows2000 box with an id and
password similar to what was configured in smbpasswd.

Hereunder is a copy of smb.conf file as additional information:

[kdua at Abeokuta]# more /usr/local/samba/lib/smb.conf
# Global Parameters
        workgroup =  WORKGROUP
        logon path = \\%N\profiles\%U
        netbios name = kdua
        interfaces =
        log file = /usr/local/samba/var/log.%m
        max log size = 50
        local master = no
        encrypt passwords = no
        guest account = nobody
        hosts allow = 10.0.0. 192.168.0. 127.
        security = user

        path = /export/home/kdua
        invalid users = root daemon operator bin games news man uucp gnats
www http nobody
        valid users = kdua jay
        public = no
        printable = no
        create mask = 0765
        read only = no
        writable = yes
        browseable = no

# Comment = temporary files
        path = /tmp
        read only = yes
        user = kdua

        path = /export/home/kdua
        read only = yes
        valid users = kdua jay

        read only = no
        create mask = 0600
        directory mask = 0766
        browseable = yes

I am hoping somebody is this audience will help me in resolving the issue/s
that I have.


More information about the samba mailing list