[Samba] Compilation problem with samba2.2.4

Jukka Holopainen jukka.holopainen at vtt.fi
Mon May 20 04:20:02 GMT 2002

Hello from Finland.

I have couple problem to compile Samba 2.2.4
I need LDAP options, and when I run
./configure --with-ldapsam everything going ok,
but when I run
It gives couple error messages, thats are below:

Compiling passdb/pdb_ldap.c
"passdb/pdb_ldap.c", line 76: undefined symbol: LDAP_OPT_X_TLS_HARD
"passdb/pdb_ldap.c", line 96: undefined symbol: LDAP_OPT_SUCCESS
"passdb/pdb_ldap.c", line 128: undefined symbol: LDAP_OPT_X_TLS
cc: acomp failed for passdb/pdb_ldap.c
*** Error code 2
make: Fatal error: Command failed for target `passdb/pdb_ldap.o'

I run Sun Netra X1, with Solaris 8 and I using iPlanet LDAP-server,
I allready download iPlanet SDK

I copy ldap.h and lber.h from this kits, but it doesn't help.

I think I need some library or headers files more, but what and
where I can fount it?

I can compile Samba 2.2.4 with default okey.
And if I first compile only default and it work,
and after that I run ./configure --with-ldapsam
and when I run make it compile anly one files not
that , can I do that and make Samba work with LDAP?

I use to Sun Forte C 6.0 compiler.

Regards: Jukka Holopainen

VTT Electronics
Kaitoväylä 1
90570 Oulu

jukka.holopainen at vtt.fi

If somebody of yor group are planning coming to
Finland and Oulu  I buy Pizza to him or her

More information about the samba mailing list