[Samba] WinY2k Access Denied on Printing

Van Sickler, Jim vansickj-eodc at Kaman.com
Fri May 17 09:31:03 GMT 2002

> -----Original Message-----
> From: Adam Williams [mailto:adam at morrison-ind.com]
> Sent: Friday, May 17, 2002 8:54 AM
> To: Van Sickler, Jim
> Cc: samba at lists.samba.org
> Subject: RE: [Samba] WinY2k Access Denied on Printing
> >>>I assume this sentence:
> >>>re-add they can't print for a little while before
> >>>really should be: re-add they can print for a little while before
> >>Yes.
> >>>This sounds like authentication (how would I know).
> >>This identical config worked without this problem under Samba 
> >>2.2.1a.  If  it was authenitcation how would they be able 
> to print at all? 
> >>It does work, but only for awhile.
> >>>Have you tried easing up on the security, making the print 
> >>share guest ok =yes.
> >>Every printer queue stanza looks like this:
> >> [traps]
> >>         comment = Traverse City Optra Laser Printer
> >>         path = /tmp
> >>         create mask = 0700
> >>         guest ok = Yes
> >>         printable = Yes
> > 
> >1.  I'd get rid of the create mask =
> >2.  Create /var/spool/samba/traps
> >3.  chmod -R 01777 /var/spool/samba
> >4.  chown -R root.wheel /var/spool/samba
> >5.  set your [traps] path = /var/spool/samba/traps
> >6.  create /var/spool/lpd/traps
> >7.  in /etc/printcap, set traps' :sd=/var/spool/lpd/traps:
> Ok, i modified one of my queues -
> [grdps]
>         comment = Grand Rapids Optra Laser Printer
>         path =  /var/spool/samba/grdps
>         guest ok = Yes
>         printable = Yes
> ls -l /var/spool/samba
> total 0
> drwxrwxrwt    2 root     wheel           6 May 17 11:42 grdps
> Restarted smbd, and it does the same thing.
> I really appreciate the help, but i think your missing some important 
> facts -
> 1. UNIX printing works flawlessly (this box is an lpd server 
> for lots of 
> unix clients).
> 2. Samba printing from both Win9x and WinY2k worked flawlessly under 
> 2.2.1a, for a long time.
> 3. Printing does work, but only for awhile. And ONLY WinY2k 
> clients are 
> effected, Win9x clients continue to print just fine

I did miss the important facts :-(

Do you have "disable spoolss=no" in smb.conf?  If so, try "=yes"
That is particular to Win2k;  Win9x clients aren't affected.

Is it happening on all of your Win2k clients?

Who, if anyone, is set up as "admin users=" or "printer admin="?
If I'm set up as an admin user in smb.conf, with "disable spoolss=no",
I get the "access denied" msg when I try to get the printer's properties;
don't know how print jobs went...never got that far.

What port does Win2k say the printer is attached to?  If it started out
on a 2.2.1a box, it may say "LanMan Printer Port".  If you
removed it and re-installed it with 2.2.4 as a "network printer" and
"disable spoolss=no", it may say that it's a Local Port.  Try
setting "disable spoolss=yes" and see if it'll let you reconnect it
to the LanMan Printer Port.

I had to set "disable spoolss=yes" on my server, because of all
the hassles it was causing when the printer was added as a
"Network Printer"...never tried it as a "Local Printer" with

1.  Conflicts with members of "printer admins" and "admin users"
- couldn't view printer properties
2.  Printer installed under HKey_Current_User, not
- If I logged into the PC as Administrator and installed the
printer, it didn't show up when I logged in under my account
3.  Couldn't modify printer settings (memory, device settings, etc.)
4.  SIDS displayed under Security tab;  not Domain\Domain Users, etc.
5.  Could view Properties on samba printer icon under Printers-as long
as the printer wasn't installed on my PC and 'admin users=" was rem'd
out (I'm in the Wheel group) or @wheel and vansickj weren't present.
6.  I couldn't install the AdobePS or LexMark drivers onto the samba
server;  they only install on the local PC.  I did manage to install
the HP drivers onto the samba server;  even with "disable spoolss=yes"
the drivers install onto the Win2k PCs just fine from the server now-
a good thing...the only good thing, out of a lot of manhours :-(
6.  Many other oddities which I can't specifially recall right now...
but will torment me at night for some time to come, I'm sure!

How it behaves with "disable spoolss=no" and the printer added to
my system as a "Local Printer", I'll never know.  I've put off too
many other jobs while fighting with samba for the last  several
weeks.  I've got to attend to them, and let someone else bloody their
forehead for a while.....


More information about the samba mailing list