[Samba] WinY2k Access Denied on Printing

Konkol, Josh JKonkol at guidemail.com
Fri May 17 09:04:02 GMT 2002

What is your printer admin set to ??  

What is your security set to ??

I had a problem with 2.2.4 where anyone who fell into the category of
printer admin was denied access to the properties of the printer BUT it only
happened to w2k and xp, NT worked fine. I realize this isn't the same error
but it's worth a try.  

Josh Konkol, CNE MCSE  
Senior Network Analyst
GuideOne Insurance
Mail Stop AB-1
jkonkol at guidemail.com

/( )\

-----Original Message-----
From: Adam Williams [mailto:adam at morrison-ind.com]
Sent: Friday, May 17, 2002 10:54 AM
To: Van Sickler, Jim
Cc: samba at lists.samba.org
Subject: RE: [Samba] WinY2k Access Denied on Printing

>>>I assume this sentence:
>>>re-add they can't print for a little while before
>>>really should be: re-add they can print for a little while before
>>>This sounds like authentication (how would I know).
>>This identical config worked without this problem under Samba 
>>2.2.1a.  If  it was authenitcation how would they be able to print at all?

>>It does work, but only for awhile.
>>>Have you tried easing up on the security, making the print 
>>share guest ok =yes.
>>Every printer queue stanza looks like this:
>> [traps]
>>         comment = Traverse City Optra Laser Printer
>>         path = /tmp
>>         create mask = 0700
>>         guest ok = Yes
>>         printable = Yes
>1.  I'd get rid of the create mask =
>2.  Create /var/spool/samba/traps
>3.  chmod -R 01777 /var/spool/samba
>4.  chown -R root.wheel /var/spool/samba
>5.  set your [traps] path = /var/spool/samba/traps
>6.  create /var/spool/lpd/traps
>7.  in /etc/printcap, set traps' :sd=/var/spool/lpd/traps:

Ok, i modified one of my queues -
        comment = Grand Rapids Optra Laser Printer
        path =  /var/spool/samba/grdps
        guest ok = Yes
        printable = Yes

ls -l /var/spool/samba
total 0
drwxrwxrwt    2 root     wheel           6 May 17 11:42 grdps

Restarted smbd, and it does the same thing.

I really appreciate the help, but i think your missing some important 
facts -

1. UNIX printing works flawlessly (this box is an lpd server for lots of 
unix clients).
2. Samba printing from both Win9x and WinY2k worked flawlessly under 
2.2.1a, for a long time.
3. Printing does work, but only for awhile. And ONLY WinY2k clients are 
effected, Win9x clients continue to print just fine

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list