[Samba] WinY2k Access Denied on Printing

Adam Williams adam at morrison-ind.com
Fri May 17 08:56:02 GMT 2002

>>>I assume this sentence:
>>>re-add they can't print for a little while before
>>>really should be: re-add they can print for a little while before
>>>This sounds like authentication (how would I know).
>>This identical config worked without this problem under Samba 
>>2.2.1a.  If  it was authenitcation how would they be able to print at all? 
>>It does work, but only for awhile.
>>>Have you tried easing up on the security, making the print 
>>share guest ok =yes.
>>Every printer queue stanza looks like this:
>> [traps]
>>         comment = Traverse City Optra Laser Printer
>>         path = /tmp
>>         create mask = 0700
>>         guest ok = Yes
>>         printable = Yes
>1.  I'd get rid of the create mask =
>2.  Create /var/spool/samba/traps
>3.  chmod -R 01777 /var/spool/samba
>4.  chown -R root.wheel /var/spool/samba
>5.  set your [traps] path = /var/spool/samba/traps
>6.  create /var/spool/lpd/traps
>7.  in /etc/printcap, set traps' :sd=/var/spool/lpd/traps:

Ok, i modified one of my queues -
        comment = Grand Rapids Optra Laser Printer
        path =  /var/spool/samba/grdps
        guest ok = Yes
        printable = Yes

ls -l /var/spool/samba
total 0
drwxrwxrwt    2 root     wheel           6 May 17 11:42 grdps

Restarted smbd, and it does the same thing.

I really appreciate the help, but i think your missing some important 
facts -

1. UNIX printing works flawlessly (this box is an lpd server for lots of 
unix clients).
2. Samba printing from both Win9x and WinY2k worked flawlessly under 
2.2.1a, for a long time.
3. Printing does work, but only for awhile. And ONLY WinY2k clients are 
effected, Win9x clients continue to print just fine

More information about the samba mailing list