[Samba] WinY2k Access Denied on Printing

Adam Williams adam at morrison-ind.com
Fri May 17 05:07:04 GMT 2002

>I assume this sentence:
>re-add they can't print for a little while before
>really should be: re-add they can print for a little while before


>This sounds like authentication (how would I know).

This identical config worked without this problem under Samba 2.2.1a.  If 
it was authenitcation how would they be able to print at all?  It does 
work, but only for awhile.

>Have you tried easing up on the security, making the print share guest ok =yes.

Every printer queue stanza looks like this:

        comment = Traverse City Optra Laser Printer
        path = /tmp
        create mask = 0700
        guest ok = Yes
        printable = Yes

>>I have a Red Hat Linux release 7.1 (Seawolf) Samba 2.2.4 PDC and fileserver
>>built with --with-ldapsam.  The clients are either win9x or WinY2k. 
>>Authenitcation, etc... all works great.
>>But print sharing is a real pain.  Under 2.2.1a printing worked great,  but our
>>VOIP phone system wouldn't joint the domain until we upgraded to 2.2.4.  Initial
>>testing of 2.2.4 made it seem like everything worked.  But eventually WinY2k
>>users can't print, they simply get access denied.  If they remove the printer
>>and re-add they can't print for a little while before it goes back to access denied.
>>ANY assistance would be greatly appreciated.

More information about the samba mailing list