[Samba] Unable to validate owner sid.

Thierry ITTY thierry.itty at besancon.org
Thu May 16 06:47:02 GMT 2002

A 07:38 16/05/02 -0500, Gerald Carter a écrit :
>On Wed, 15 May 2002, Mead, Tom wrote:
>> This is a problem that i have reported previously and from what i gather
>> it is a known bug that is being worked on. The error message has changed
>> slightly since previous samba 2.2.X versions. The following log extract
>> is taken from the same problem with samba 2.2.3a -
>> > [2002/02/21 11:15:44, 3] smbd/posix_acls.c:unpack_nt_owners(443)
>> >   unpack_nt_owners: unable to validate owner sid.
>> Note the missing "for S-1-5-21-1456024563-1430335328-122644288-2355" that i
>> now get with 2.2.4
>> This application has worked fine with samba 2.0.X with WINNT clients for
>> a couple of years but this problem is now preventing me from upgrading
>> not only samba 2.0.X to 2.2.X but WINNT to 2000 and Solaris2.6 to
>> Solaris 8. If anyone can give me an idea of why this is happening, if
>> there is a way around it, and if there is likely to be a fix for it soon
>> it would be appreciated.
>OK. You are not running winbindd correct?  Is this a domain SID
>or the SID of the local Samba box?

might this be related to the following problem ?

[root at server share]# /usr/local/samba/bin/smbcacls //server/share file -U

INFO: Debug class all level = 2   (pid 13443 from pid 13443)
added interface ip=a.b.c.d bcast=a.b.c.255 nmask=
error connecting to a.b.c.d:445 (Connection refused)
failed session setup
cli_pipe: return critical error. Error was NT_STATUS_NETWORK_NAME_DELETED
ACL:cli_pipe: return critical error. Error was NT_STATUS_NETWORK_NAME_DELETED
ACL:cli_pipe: return critical error. Error was NT_STATUS_NETWORK_NAME_DELETED
[root at server share]#

SIDs are either local or domain SIDs
			- * - * - * - * - * - * -
Bien sûr que je suis perfectionniste !
Mais ne pourrais-je pas l'être mieux ?
	Thierry ITTY
eMail : Thierry.Itty at Besancon.org		FRANCE

More information about the samba mailing list