[Samba] Unable to validate owner sid.

Gerald Carter jerry at samba.org
Thu May 16 05:42:04 GMT 2002

On Wed, 15 May 2002, Mead, Tom wrote:

> This is a problem that i have reported previously and from what i gather
> it is a known bug that is being worked on. The error message has changed
> slightly since previous samba 2.2.X versions. The following log extract
> is taken from the same problem with samba 2.2.3a -
> > [2002/02/21 11:15:44, 3] smbd/posix_acls.c:unpack_nt_owners(443)
> >   unpack_nt_owners: unable to validate owner sid.
> Note the missing "for S-1-5-21-1456024563-1430335328-122644288-2355" that i
> now get with 2.2.4
> This application has worked fine with samba 2.0.X with WINNT clients for
> a couple of years but this problem is now preventing me from upgrading
> not only samba 2.0.X to 2.2.X but WINNT to 2000 and Solaris2.6 to
> Solaris 8. If anyone can give me an idea of why this is happening, if
> there is a way around it, and if there is likely to be a fix for it soon
> it would be appreciated.

OK. You are not running winbindd correct?  Is this a domain SID
or the SID of the local Samba box?

cheers, jerry
 Hewlett-Packard                                     http://www.hp.com
 SAMBA Team                                       http://www.samba.org
 --                                            http://www.plainjoe.org
 "Sam's Teach Yourself Samba in 24 Hours" 2ed.      ISBN 0-672-32269-2
 --"I never saved anything for the swim back." Ethan Hawk in Gattaca--

More information about the samba mailing list