[Samba] RE: printer admin problems with 2.2.4

Martin Thomas mthomas at rhrk.uni-kl.de
Wed May 15 13:42:03 GMT 2002

>We upgraded from 2.2.3a to 2.2.4 on a SuSE 7.2 server. We compiled Samba just 
>default. The new version seems to work ok with the exception of printer administration.
>Printer admins are not able to see the properties of the printers (right click on printer 
>gives on error). Our workstations are W2k SP2. But users that are not printer admin 
>are able to see the properties of a printer, but they are not allowed to change the 
>settings or to upload drivers. I don't think it is important, but we use the latest lprng-
>version as printserver. 
>*   We tried the patch on the file rpc_parse/parse_spoolss.c
>*   We tried the current CVS version
>*   We installed the whole samba from scratch (new tdb-files)
>All no difference.
>With a lot of debugging on we can't see what is the problem. 
>Any ideas? 
>Met vriendelijke groet/Regards,
>R.J. Baart

Had the same problems here too. It seems that Windows 2K stores 
a lot of  information about the printers in the registry (~=user-profile). 
Esp. if the printers where connected via local ports and with local drivers
before, this seems to be stored in the registry and is not always removed if the
printer gets disconnected/removed. Try to find you printer-names in the registry and
delete entries around it (...registry, hacking, backup, warning etc.etc.). 
You may also clean up /winnt/system32/spool/drivers.

Perhaps you can just take another W2K client (clean installation) and fire
the Server APW from there and use a 'clean' clients to test it.

With one Printer (a HP Deskjet 1120 connected via a JetDirect 300x Box,
served via 'latest' LPRNG and Samba 2.2.4 using the W2K standard drivers
from /winnt/inf/ntprint.inf) I had exactly the same problem that you've 
described. The printer properties could be edited by a print-admin as 
long as none of the clients was connected to the samba-queue.
It seems to work now after heavy registry-editing, client file-removal,
new tdb and latest CVS-Code (but with only two clients connected so far).

Please send me your findings, I'm fighting with this problem too and
would like to have more information on it.


More information about the samba mailing list