[Samba] printer admin problems with 2.2.4

Ruud Baart R.J.Baart at Prompt.nl
Wed May 15 08:54:02 GMT 2002

We upgraded from 2.2.3a to 2.2.4 on a SuSE 7.2 server. We compiled Samba just 
default. The new version seems to work ok with the exception of printer administration.

Printer admins are not able to see the properties of the printers (right click on printer 
gives on error). Our workstations are W2k SP2. But users that are not printer admin 
are able to see the properties of a printer, but they are not allowed to change the 
settings or to upload drivers. I don't think it is important, but we use the latest lprng-
version as printserver. 

*   We tried the patch on the file rpc_parse/parse_spoolss.c
*   We tried the current CVS version
*   We installed the whole samba from scratch (new tdb-files)
All no difference.

With a lot of debugging on we can't see what is the problem. 

Any ideas? 

Met vriendelijke groet/Regards,
R.J. Baart

Marktveldpassage 35c
5261 ED Vught
Mailto:R.J.Baart at Prompt.NL
Tel.: +31 73 6567041                          
Fax.: +31 73 6573513

More information about the samba mailing list