[Samba] samba printer driver uploading

xero xero at tfz.net
Tue May 14 15:42:02 GMT 2002

I am running samba and I am trying to get it to upload/download printer
drivers. When I go into the "Printers and Faxes" folder, or just
"Printers" on win2k, it shows my 2 printers, on WinXP I right click on raw1 and
go to properties, it asks to install the driver, if I click yes, it
takes me through the add printer wizard, which lets me select my printer
driver, but apparently does nothing at all. If I go to sharing tab, and
click additional drivers, and then select Windows 2000 or XP, and click
ok, it will copy a postscript driver over, but it is not the correct
driver. If I go to the advanced tab, the list of drivers is empty, if I
click new driver, it takes me through the same add printer wizard that
it does if I click yes when right clicking properties, but this time
when I select my driver, and click next, it says i'm about to install 
the driver for NT4.0 and 2000 (this is on XP) and when I click finish, 
it tells me to provide a driver and asks for a cd in the D: drive. 
Problem is, the file its looking for isn't on the cd, nor my harddrive.
I tried selecting c:\windows\inf and it pops up an error saying "Unable
to install Epson Stylus Photo EX ESC/p 2, windows nt4.0 or 2000, intel
driver. Operation could not be completed. The only thing I can do is 
click cancel to get out. On windows 2000, the sharing and advanced tab are 
shaded out and I cannot get that far. Now, what I can do is right click raw1 in 
the printers folder, go to connect, and install the driver locally, which
works fine, but that doesn't upload the printer driver and defeats the 
whole purpose. In my samba logs I found one of these, although I have tried to 
reproduce this in my logs, and have concluded this only shows up when installing
the printer driver locally. Here it is anyway.
[2002/05/14 17:19:46, 0] smbd/service.c:make_connection(252)
  xwin ( couldn't find service ::{2227a280-3aea-1069-a2de-08002b30309d}

and heres a copy of my smb.conf
workgroup = XNETWORK
server string =
hosts allow = 192.168.0. 127.
security = user
log file = /var/log/samba.%m
max log size = 50
socket options = TCP_NODELAY
load printers = yes
dns proxy = no
map to guest = bad user
printer admin = @ntadmin,xero
encrypt passwords = Yes

path = /usr/share/samba/print
guest ok = yes
browseable = yes
read only = yes
write list = @ntadmin,root,xero

comment = Epson Stylus Photo EX
path = /var/spool/samba
public = yes
writable = no
printable = yes

Any help is appreciated.

More information about the samba mailing list