[Samba] Can't access a linux server using a Win2K client

Kris Kelley skunk at simdesk.com
Tue May 14 12:15:02 GMT 2002

I wrote:
> > I am trying to configure it so that Windows 2000 machines
> > within my company's Windows domain can access it.  Before diving into
> > anything exotic, I am trying to get this to work without requiring any
> > kind of authentication.  So, this is my smb.conf file:
> >
> >   [global]
> >      workgroup = DEVGROUP
> >      security = share
> >      netbios name = skunkworx
> >   [test]
> >      comment = test share
> >      path = /export/samba/test
> >      read only = no
> >      guest only = yes
> >      guest account = nobody
> >  

Brad Langhorst wrote:
> i suggest you take a look in the log files
> after adding
> log level = 2
> to your global section
> /var/log/samba/log.smbd

Here is the log file after I restarted Samba and again tried to access
it from a Win2K box:

   [2002/05/14 13:23:22, 0] smbd/server.c:main(707)
     smbd version 2.2.4 started.
     Copyright Andrew Tridgell and the Samba Team 1992-2002
   [2002/05/14 13:23:22, 0] lib/debug.c:debug_message(257)
     INFO: Debug class all level = 2   (pid 1174 from pid 1174)
   [2002/05/14 13:23:22, 2] param/loadparm.c:do_section(3024)
     Processing section "[test]"
   [2002/05/14 13:23:22, 2] lib/interface.c:add_interface(81)
     added interface ip= bcast= nmask=
   [2002/05/14 13:23:22, 2] smbd/server.c:open_sockets(215)
     waiting for a connection
   [2002/05/14 13:24:23, 2] smbd/reply.c:reply_special(91)
     netbios connect: name1=SKUNKWORX        name2=NFSTEST        
   [2002/05/14 13:24:23, 2] smbd/reply.c:reply_special(110)
     netbios connect: local=skunkworx remote=nfstest
   [2002/05/14 13:24:23, 2] smbd/server.c:exit_server(461)
     Closing connections

   [2002/05/14 13:25:21, 2] smbd/reply.c:reply_special(91)
     netbios connect: name1=SKUNKWORX        name2=NFSTEST        
   [2002/05/14 13:25:21, 2] smbd/reply.c:reply_special(110)
     netbios connect: local=skunkworx remote=nfstest
   [2002/05/14 13:25:21, 2] smbd/server.c:exit_server(461)
     Closing connections

The last six lines were generated when NFSTEST, a Win2K box within the
DEVGROUP domain, tried to access SKUNKWORX.  The same "account is not
authorized" error as before happened again.

> another thing to try is to up your sambabox in a different workgroup (ie 
> devgroup2)

Curiously, this didn't have any effect.  First I tried group WORKGROUP,
which exists and has one other computer, then I tried MYOWNGROUP, which
no other machines in our network are using.  Both times, SKUNKWORX still
appeared in group DEVGROUP when listing the network from the Win2K box,
and both times SKUNKWORX still refused access to its shares.

I should mention that SKUNKWORX is a dual-boot box, and before I started
playing with Samba, SKUNKWORX was in the DEVGROUP domain as a Win2K
box.  Would that affect Samba's operation somehow?  I am not savvy in
Windows domain administration, but I can get our Windows sysadmin
involved in this project if need be.

Jim Hale wrote:
> > I kind of solved the problem. I noticed that when I installed
> > 2.2.4 (RPM) it made a backup of my smb.conf (called
> > smb.conf.rpmsave) - I deleted the smb.conf, renamed the .rpmsave and
> > Voila! I got my drive access back. :)

Joel Hammer wrote:
> It might be nice to share what is in your current smb.conf file, since
> that seems to have solved the problem.

I'm also interested in seeing it, if that's okay.

Thanks for the replies so far!

---Kris Kelley

More information about the samba mailing list