[Samba] Solaris 2.8 Samba 2.2.[2|4]/CUPS 1.1.14 compilation problem

Duncan Grove duncan at cs.adelaide.edu.au
Tue May 14 01:46:02 GMT 2002


I've been trying to get Samba so tie with our departmental
CUPS ssetup. I tried setting:

        load printers = yes
        printing = cups
        printcap name = cups

etc in the smb.conf, but after a while discovered in log.smbd that:

[2002/05/14 17:24:22, 0] printing/pcap.c:pcap_printer_fn(373)
  Unable to open printcap file cups for read!

(Aside but possibly of interest - this explained why I couldn't get
the cupsaddsmb command to work properly! It also seemd that Samba's
rpcclient program was not working according to spec: rpcclient
localhost -options didn't work but rpcclient -options localhost

I presume this is because our Samba server was not configured with
CUPS support. So, I've gone back to try and do that, but for the life
of me can't get it to happen. (CUPS has already been compiled and
works fine). I'm using:

./configure --prefix=/opt/samba-2.2.4

I've also tried setting:


But continue to get:

checking for httpConnect in -lcups... no

As far as I can tell from the configure script (which is not much)
this is not good. Checking manually shows that:

nm /opt/cups-1.1.14/lib/libcups.a | grep httpConnect
         U httpConnect
000000e0 T httpConnect
00000114 T httpConnectEncrypt
         U httpConnectEncrypt

What am I doing wrong?

Thanks for your help!


Duncan Grove
duncan at cs.adelaide.edu.au
Dream on together, leaning against each other
However it happens I hope it's whatever makes you happy <><

More information about the samba mailing list