[Samba] Can't access a linux server using a Win2K client

Kris Kelley skunk at simdesk.com
Mon May 13 16:52:02 GMT 2002

Hello all.  I am new to Samba, so forgive me if this is a stupid
question, but I have been unable to figure this out.

I have a Red Hat 7.1 box (kernel 2.4.9) with the Samba 2.2.4-2 RPM
installed.  I am trying to configure it so that Windows 2000 machines
within my company's Windows domain can access it.  Before diving into
anything exotic, I am trying to get this to work without requiring any
kind of authentication.  So, this is my smb.conf file:

      workgroup = DEVGROUP
      security = share
      netbios name = skunkworx
      comment = test share
      path = /export/samba/test
      read only = no
      guest only = yes
      guest account = nobody

The relevant directory, /export/samba/test, does exist, and has 777

When Samba is running, SKUNKWORX shows up in a listing of the Windows
domain, but all attempts to access the share have failed with the error
message "\\Skunkworx is not accessible.  The account is not authorized
to log in from this station."  An Internet search led me to believe this
problem usually happens because Win2K machines use encrypted passwords
by default, which a Samba set-up like mine would not support.  However,
because I am trying to bypass the use of passwords altogether (for now),
I do not believe this is my problem.  Still, I went ahead and tried the
suggested registry hack, enabling Win2K to use plain-text passwords.  No

I can supply the dump from testparm, and I can also supply the logs from
smbd when I tried this with debug level 3, if any of that will help. 
Any assistance will be greatly appreciated.  If this question has been
answered before, feel free to direct me to the appropriate archives (I
didn't see any search options available).  Thank you.

---Kris Kelley

More information about the samba mailing list