[Samba] Re: Linux, Samba, and the Lexmark z53

Joel Hammer Joel at HammersHome.com
Sat May 11 18:54:02 GMT 2002

Some comments, in no particular order:
You are going to have to start reading the logs to see what is going on.
I would remove valid users from your printer definition.
Make sure security=share in the global section.
I would use the real name of the print queue in place of %p.
The first issue to solve is why you are not getting the files transferred
from you windows clients to the /tmp spool directory. To that end, I would
delete the rm %s from the printer command. Make sure there is a real guest
account. I use ftp.
The logs may help. (/var/log/messages, /var/log/samba,
/usr/local/samba/var/, and the status files in your printer queue.

I assume this means you got two pages printed:
>   Under this setup the printer icon in WinXP actually has the word "ready" written under it, which was never there before... but printing a test page yields only the result described earlier.
NOTE: lpc is in /usr/sbin. 

On Sat, May 11, 2002 at 06:06:11PM -0700, adrian kaehler wrote:
>   Ok, so on the "lprng" issue, that seems to be what I have.  I ran checkpc, and got the following message:
>  [adrian at valor lexmarkz53]# checkpc
> Warning - permissions of '/var/spool/lpd/lexmarkz53' are 0777, not 0700
> So if having checkpc implies having lprng, then that's me.  Also if Redhat 7.1 uses it, it is at least reasonbable to suspect that RH 7.2 does as well.
>   Currently however, I am unable to get anything to print on the printer, garbage or otherwise.  When I attempt to print a test page from WinXP, I get a popup that says something like "Print failed, would you like to run the troubleshooter?" (as if that would help).  Of course I click "no" and that's that.  If I go to the linux machine, I see that there is a file in /tmp (this is where it should be yes? Because that is the "path" variable in the smb.conf file?) with a name like smbprn.DK41em, but it is size zero bytes.  As I waited for your response I was reading elsewhere, and reorganized the [lex] entry in my smb.conf file to read:
> [lex]
>   printing = lprng
>   printer = z53-outfiles
>   printer name = z53-outfiles
>   comment = Raw Printer for Z53
>   path = /tmp
>   create mask = 0700
>   guest ok = yes
>   hosts allow = 192.168.
>   valid users = smbuser
>   printable = yes
> ;  print command = echo "Tried to print %s" > /tmp/junk.%s
>   print command = /usr/bin/lpr -P %p %s; rm %s
>   lpq command = /usr/bin/lpq -P %p
>   lprm command = /usr/bin/lprm -P %p %j
>   lppause command = /usr/bin/lpc hold  %p %j
>   lpresume command = /usr/bin/lpc release  %p %j
>   printer driver = Lexmark Z53 Series ColorFine
> ;  printer driver location = \\VALOR\public\Adrian\Drivers Etc\lxkz53
>   share modes = No
>   Now, I am not sure what the difference between "printer" and "printer name" is, but I set them both to the queue you suggested "z53-outfiles", and changed the explicit references to "lp" to the meta "%p" which my reading suggests interpolates either "printer" or "printer name", but I do not know which (so I made them the same).
>   Under this setup the printer icon in WinXP actually has the word "ready" written under it, which was never there before... but printing a test page yields only the result described earlier.

  Also it should be mentioned that any attempt to print from any other WinXP application gives an "Invalid HANDLE error", which results in no print attempted.
>   So at the moment, my issues is how to get WinXP to thing the print was successful, which I would think is at least correlated with getting the smbpm.XXXXX file to appear in /tmp, and maybe even printed... but for now, I can not even get the garbage files that I was seeing a few weeks ago (then under some strange configuration involving BSD and other things lost in the annals of history now).
>   Thanks again for all of your help,
>     -Adrian
>   Joel Hammer <Joel at HammersHome.com> wrote: Actually, never having used bsd or cups, I wouldn't really know.
> If you have checkpc and it works, you likely have lprng. RedHat
> 7.1 used lprng. 
> Since printing goes for two lines and stops, you may fine something of
> interest in the status files in your print queue.
> Have you tried just cat'ing the file in the /tmp spool to lp0?
> The type of printing software you have on linux won't affect the cat'ing
> experiment.
> Joel
> ---------------------------------
> Do You Yahoo!?
> LAUNCH - Your Yahoo! Music Experience

More information about the samba mailing list