[Samba] Samba - cannot print multiple copies

Maithri Samuel mikesamuel at shaw.ca
Fri May 10 12:30:03 GMT 2002


I successfully setup printing on my FreeBSD box 
using Samba with apsfilter and lprng. However, I 
have encountered two issues:

1) Cannot print multiple copies of documents from
my windows box (e.g. notepad). Only the first
copy is printed and the rest don't get printed.
2) My spool directory is getting filled up and
I would like the job removed after the print
job is finished

I've tried:
- selecting collated and not collated in the
windows printing, that didn't fix the problem. 
Still one copy printed.
- adding lpd_bounce in both and also one at a time in 
the /etc/printcap and in the /usr/local/etc/lpd.conf. 
/etc/printcap -> added :lpd_bounce:\ before my :mx line
/usr/local/etc/lpd.conf -> changed to
#   default lpd_bounce (FLAG on)
Still one copy printed. Changed them back to not have 
lpd_bounce but still only one copy ;)
- even when I do lpr -r DOC_NAME in FreeBSD,
it still leaves stuff in the spool directory.
I use lprm - to flush it

Things I've setup:
- using the default lpd.conf and lpd.perms files.
- not running passwords or custom freebsd users on samba.
Strictly guest access by user nobody.
- set up mode 1777 on the samba print dir
- Ran checkpc -f -V. No problems. Had an old 
problem of not being able to access /dev/lpt0 but 
I fixed the access privilages (still wierd that
we have to do that, the freebsd installed lpr 
didn't require that, why does lprng require
changing the port's access rights?)
- I can print multiple copies from the FreeBSD
box if I run lpr -#N, up to the 20 limit I 
specified below.

I will greatly appreciate help in fixing
these two problems. I've included my setup files
below. If there is any else that is required,
please reply and I will include the details of
that as well.



Current setup is:
Windows 2000 client
FreeBSD 4.5 server 

# APS1_BEGIN:printer1
# - don't delete start label for apsfilter printer1
# - no other printer defines between BEGIN and END LABEL
# APS1_END - don't delete this

load printers = yes
use client driver = yes
printing = lprng
guest account = nobody
max log size = 50
security = share
socket options = TCP_NODELAY 
dns proxy = no 
domain master = yes
preferred master = yes

#print command = /usr/local/bin/lpr -U%U%M -P%p -r %s;
print command = /usr/local/bin/lpr -P%p %s;\
rm %s
lpq command = /usr/local/bin/lpq -P%p %s
lprm command = /usr/local/bin/lprm -P%p %j
lppause command = /usr/local/sbin/lpc hold %p %j
lpresume command = /usr/local/sbin/lpc release %p %j
queuepause command = /usr/local/sbin/lpc -P%p stop
queueresume command = /usr/local/sbin/lpc -P%p start

#============================ Share Definitions 
    comment = Temporary Server file area
    path = /tmp
    read only = no
    public = yes
    writeable = yes
    guest ok = yes

   comment = All printers
   path = /var/spool/samba
   browseable = no
   printer = raw
   printer name = HP-Deskjet-560C
   public = yes
   guest ok = yes
   writeable = no
   printable = yes

More information about the samba mailing list