[Samba] Samba 2.2.4 and SCO Openserver 5.0.6

Michael Charles m.charles at bacuk.com
Fri May 10 02:24:03 GMT 2002

Hi Dirk,
I have disables lines 664 to 668 in Makefile. When it I run "make" I still
get this error "Compiling smbd/server.c
include/includes.h, line 855:error: identifier redeclared: initgroups
*** Error code 1 (bu21)"
I have run configure with and without winbind and get the same error above.

-----Original Message-----
From: Dirk ALLAERT [mailto:Dirk.Allaert at schaubroeck.be]
Sent: 09 May 2002 19:32
To: Michael Charles; samba at lists.samba.org
Subject: RE: [Samba] Samba 2.2.4 and SCO Openserver 5.0.6

line 664: Syntax error.

I also got this error on Openserver. I just deleted line 664  to 668 in the
Makefile and it worked fine. I guess the Openserver make is just too ancient

        @echo "Linking $@"
        @$(SHLD) -shared -o $@ $(WINBIND_NSS_PICOBJS)  \
                #`basename $@`

I could be wrong but AFAIK Openserver does not not support NSS so winbind
will not work.

-----Oorspronkelijk bericht----- 
Van: Michael Charles 
Verzonden: do 9/05/2002 14:29 
Aan: 'samba at lists.samba.org' 
Onderwerp: [Samba] Samba 2.2.4 and SCO Openserver 5.0.6

I have problems installing the latest release of Samba on Caldera (SCO)
Openserver 5.0.6

I have downloaded the source and  ran "./configure" fine. I get an error "
line 664: Syntax error " when I run "make".  If I run " ./configure
--with-winbind", then run "make", I get the error "Compiling smbd/server.c
include/includes.h, line 885:error: identifier redeclared: initgroups
*** Error code 1 (bu21)"

I have installed the same release on SCO Unixware 7.1.0 by running
"./configure --with-winbind", " make" and finally "make install".  This


To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list