[Samba] kanji characters in filenames are not being translated properly?

Shirish Kalele kalele at veritas.com
Tue May 7 20:00:02 GMT 2002


Since Samba 2.2.x doesn't speak Unicode on the wire, you can't be in
codepage 437 (US English) mode and send Japanese codepage 932 filenames to
the Samba server. If you stayed in Japanese mode and then copied the file,
you will probably have better results..

For transfers between Windows machines, it doesn't matter which codepage
you're in because they use Unicode. The 3.0 branch of Samba does this


-----Original Message-----
greetings samba wizards,

i am having a problem configuring Samba to accept kanji characters in
filenames.  i have tried the latest samba 2.2.4 and samba 2.2.2-ja (from
samba.gr.jp) and both exhibit the same behavior.  i have a windows 2000
desktop client (although in the final configuration there will be a mix of
98/nt/2k machines) with japanese language support installed.  i didn't
how to otherwise create a file with a kanji filename (i'm an english
with nearly no japanese familiarity) so i switched my desktop to japanese
and made a shortcut to a control panel (the "regional options" control to
exact) on my desktop.  i switched my language back to english, logged out
and back in and then tried copying the file  (which still had a kanji
filename) to my Samba server.  it copied, but the filename showed up as
"????" when it was done copying (well, first it showed up as "~07" but
i turned off "mangled names" in smb.conf).  the filename on the linux box
just ????.lnk, but i wrote a quick perl script to convert the filenames to
octal and the ?'s are 036.  this happens no matter which coding system i
(i have tried euc, hex, and sjis).  however, when i copy the same file to
windows 2000 fileserver, it shows up as kanji characters.

here is my config file:

        log file = /var/log/smbd.log
        debug level = 65535
        workgroup = SCALE8
        netbios name = smc1
        interfaces =
        max smbd processes = 0
        socket options = TCP_NODELAY SO_SNDBUF=65536
        security = share
        encrypt passwords = Yes
        oplocks = false
        client code page = 932
        coding system = SJIS
        mangled names = no

        path = /tmp
        writeable = yes
        guest ok = yes

i have dug through the mailing list archives and all the howtos i could
and haven't seen this problem.  can anyone help me?  i am not on this list
so please reply to me directly..

thanks in advance,

More information about the samba mailing list