[Samba] 2.2.x Printing from Win2k-more clues

Van Sickler, Jim vansickj-eodc at Kaman.com
Tue May 7 17:20:11 GMT 2002

I've discovered a couple of things while
troubleshooting my printer setup problems.

1.  print$ must be 0744.  I ran a level-3
debug, and was seeing "chmod failed" errors.
Upping it to level-10, I saw something that
pointed to unix rights of 0744; my dir's were
set to 0755 or 0777...neither worked.  When I
set print$ and it's subdir's to 0744,
the chmod errors went away.

2.  I'm a member of unix group "wheel".
If @wheel or vansickj are listed in the
"printer admin=" line in smb.conf, I can't
view the printer properties on either the printer
installed on my PC or the printer share on the
Samba server.  If the line is blank, I can view
both and successfully print test pages from my
PC AND the Samba server share.

3.  Once the test page is printed, it remains
listed on my PC and the Samba server as Paused.
lpstat, lpc status and lpq all show no printable
jobs in the queue, and the printer is active.

I'm running 2.2.4, lprng 3.8.10, openbsd 3.1


More information about the samba mailing list