[Samba] Trying to set-up Stunnel for samba

Neil Aggarwal neil at JAMMConsulting.com
Sun May 5 08:47:02 GMT 2002


I am trying to set-up an stunnel for samba.

On my Linux server, I have samba set-up and working
in non-ssl mode.  I set up a file share called Documents.

Then, I ran an stunnel on the command line to allow
me to tunnel thru it.  Here is what I did:
/usr/sbin/stunnel -D 7 -f 2139 -r 139

Then, on my client (A Windows 2000 machine), I
did the following:
1. Created a directory c:\bin
2. Downloaded the file
	and extracted it.
3. I then went to a command line, changed to the c:\bin directory
   and typed this command:
 	stunnel.exe -c -d -n smb -r

I then went to windows explorer and tried to add a network
place with the location \\\Documents but when it
tries to connect, I get a pop-up that says the network path
was not found.

The command line on my Windows 2000 box has this message:
LOG5[796:924]: connected from
LOG3[796:924]: remote connect: Unknown error (10060)

There are no messages on the command line on the Linux box, so it
seems that I was not able to connect to it.  This is strange since
I know that it is not a firewall issue.

If I compile samba with the --with-ssl option, everything works fine.

Any ideas?

Neil Aggarwal
JAMM Consulting, Inc.    (972) 612-6056, http://www.JAMMConsulting.com
Custom Internet Development    Websites, Ecommerce, Java, databases

More information about the samba mailing list