[Samba] 2 Qs, Win ME failure and SWAT issue.

Sean McHenry smchenry at columbus.rr.com
Thu May 2 23:29:02 GMT 2002

First, the SWAT issue.  I have a RH 7.2 system recently installed, lots 
of RAM and VMware 3.1 installed.  VMware did it's own SAMBA installation 
when I set it up.  I have since downloaded the latest version, and 
removed the older version that came with VMware.  Updated fine.

When I run SWAT on this machine, it says SMB is not running even though 
I can start, stop and restart it from the command line.  Says "OK" each 
time.  I found a copy of smb in the /etc/init.d directory as well as the 
newly installed copy in /etc/rc.d/init.d  Could these be conflicting as 
VMware services are sarting at boot time.  If it was using the older 
version in the /etc/init.d directory could it be that this is the reason 
SWAT is saying the version I installed was not running?  Second part of 
this question: if this is due to having VMware installed, how do I 
rectify the version issues?  That is using the right version for SAMBA 
itself and still allow VMware to start it's services on boot.

Second problem: I am able to see a /var/Shared folder on another Linux 
web server I have running SMABA (latest RH rpm version) just fine on my 
Win 2K and XP home edition machines on the smae workgroup.  My Win Me 
machines (both the real thing and the one I run inside VMware) see the 
Linux machine and that it has shares but when I try to connect, it spins 
for a few moments and then asks me to supply a password only.  It 
doesn't ask for the username.

I am going to make an assumption here - (yes I know...) that Win Me is 
similar to 98/95 in that it attempts to log you onto the shares with the 
name you logged onto the local machine with?  In which case, if I logged 
onto the WinMe machine as "Administrator", it will send "Administrator" 
as the logon to the samba box?  I suppose further that there is no way 
around this except to create a user named "Administrator" on the SAMBA box?

Am I even on the right path with these?  I will try renaming the 
/etc/init.d version of smb to old_smb and restarting my machine.  My 
guess is it will cause VMware to not boot with all it's functionality 

Thanks folks.  I did look back a few month in the Archives before asking 
these but didn't see anything on either of these specifically.

Sean McHenry
no-spam-smchenry at columbus.rr.com
(remove the "no-spam-"

Visit McHenry Technologies <http://www.mchenrytech.com> McHenry 
Technologies <http://www.mchenrytech.com>
Hilliard, Ohio
Powered by Red Hat Linux 7.2

More information about the samba mailing list