[Samba] 15-character NetBIOS name won't join domain

Herb Lewis herb at sgi.com
Wed May 1 09:05:02 GMT 2002

Ken Cross wrote:
> I've got a strange problem.  If the NetBIOS name is exactly 15
> characters (A23456789012345), it can't join a domain -- gets
> ACCESS_DENIED.  14 characters work fine, and 15 characters work fine on
> Windows clients.  I'm joining an NT4 domain.
> I've tried 2.2.2, 2.2.3a, and current (as of this morning) - same
> results.  I'm running on NetBSD.
> Does anyone use 15-character names with success?
> Ken

I just tried it on my IRIX machine running the latest CVS with no 
problem. I set "netbios name =" to a 15 character name. Ran smbpasswd
to join the NT4 domain, and then was able to access the samba machine
from the PDC with no problem. Can you give more details on exactly 
what failed (maybe with the message from a level 10 log).
Herb Lewis                               Silicon Graphics 
Networking Engineer                      1600 Amphitheatre Pkwy MS-510
Strategic Software Organization          Mountain View, CA  94043-1351
herb at sgi.com                             Tel: 650-933-2177
http://www.sgi.com                       Fax: 650-932-2177          

More information about the samba mailing list