[Samba] Weird problem - one machine works another doesn't on new server - both OK on old one.

Victoria Welch vikki at oz.net
Mon Jun 24 13:16:25 GMT 2002

Hi Tony,

Thanks very much for the response!

On Mon, 2002-06-24 at 12:23, Ricker, Tony wrote:
> Victoria,
> Pardon me for maybe asking the obvious, but is there anything in
> /var/log/samba for this machine? If nothing, maybe the machine is not
> hitting your box (network) or if there is, it may give you/us a place to
> start. Good luck.

I was about to respond that nothing had ended up in the logs, but
decided to look again.  Now there is something!  I'm getting:

[2002/06/23 23:48:03, 0] passdb/pampass.c:smb_pam_passcheck(827)
  smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User mswillow

The testing I was doing resulted in nothing in the logs, I assumed (heh)
that it had to do with never getting past the password prompts.  There
were FAR more attempts at this than are reflected in the log for her
machine so I don't know what that is about.  Those 5 that are there now
were the last pass before I fell over last night :-)

OK, I basically understand the message, but the password configured into
smbpasswd is the correct (99.999% SURE) password, it does indeed work
for logging into the linux box in question.  I have reset it a number of
times in smbpassword very carefully so I am pretty sure it is right

However, this gives me something to think about, although I am not sure
what.  At least samba is now responding to Jeans box.

Scratching head...

Thanks & take care, Vikki.
> Cheers,
> Tony
> -----Original Message-----
> From: Victoria Welch [mailto:vikki at oz.net]
> Sent: Monday, June 24, 2002 2:20 PM
> To: samba at samba.org
> Subject: [Samba] Weird problem - one machine works another doesn't on
> new server - both OK on old one.
> Hello and Thanks in Advance,
> I've been at this for three days now and can't think of anything else to
> try.  Been through the docs and #samba on openprojects and even begged
> for direction in #samba-technical who suggested writing here.
> On the ancient RedHat 5.2 server (SAMBA 1.9?) both boxes work OK and
> continue to work OK with both servers now up (new one is from Mandrake
> 8.2 - SAMBA 2.x).
> On the new server one box works just fine and the other can not get a
> password through the initial password dialog when trying to connect to
> the new server.
> All passwords tried were current and valid ( work for login to both the
> linux box and the w98 boxes).
> smbpassword is established for both users.
> The second machine (willow) is equivalent to "jeanne" on the linux box
> (the other the SMB name and linux box name are the same).
> The above is mapped in smbusers:
> jeanne = willow
> I've tried everything I can think of with no luck with the second box. 
> I did try encrypted and unencrypted passwords, all that gets me is that
> then both boxes can't find a valid password to get at the new server.
> Old server continues to work with no problems.
> Appreciate any suggestions on this matter, GREATLY!
> Thanks & take care, Vikki.
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list