[Samba] Login script doesn't run - Solved

Bob Crandell bob at assuredcomp.com
Sat Jun 22 09:42:02 GMT 2002

I hate being stupid.  Here is the answer:
This won't work:
        logon script = %U.bat     #   Win9x needs this

This will work:
#   Win9x needs this
        logon script = %U.bat

The comment has to be on it's own line.

Thanks to all for trying to help.

Bob Crandell (bob at assuredcomp.com) wrote*:
>The login script has worked for our win98 computers since the dawn of time (or
>there abouts).  Then something happened or I did something and the login script
>doesn't run anymore.  I can run it manually.  This was version 2.2.3a.
>I started smbd with -d10 and didn't see any call for a script.  Is the login script
>mentioned in a working system?
>In an effort to fix this, I deleted and recreated the private directory
>and /var/lock/samba.  No joy.
>Here is part of the smb.conf:
>        security = user
>        encrypt passwords = yes
>        preferred master = yes
>        domain logons = yes
>        domain master = yes
>        local master = yes
>        logon script = %U.bat
>        available = yes
>        path = /home/samba
>        writable = no
>        comment = Network Logon Service
>        public = yes
>        admin users = admin, bob
>        write list = admin, bob
>I installed 2.2.5.  No joy.
>bob at assuredcomp.com
>Eugene, Or. 97402
Bob Crandell
Assured Computing
When you need to be sure.
Cell 541-914-3985
FAX  240-371-7237
bob at assuredcomp.com
Eugene, Or. 97402

More information about the samba mailing list