[Samba] mount problems with recent mount and samba

Dmitri Pogosyan pogosyan at cita.utoronto.ca
Thu Jun 20 11:18:02 GMT 2002

I have a problem mounting Samba shares with recent mount packages from 
RedHat and Samba packages from samba site. I have tried samba-2.2.4 RPM 
and samba-2.2.5 (built for RH7.2). In all cases mount fails if I use
RH mount package version > 2.11b  (current is 2.11n). If I also use 
Samba packages (2.2.4) from RedHat Rawhide - everyhting works

Here is detailed description I have submitted to RH bugzilla:

Description of problem:
After upgrading mount from 2.11b (RH 7.1) to later versions (tried - 
2.11g from 7.2,  2.11n from 7.3, 2.11n-15 from Rawhide), attempt to 
mount Samba partion via autofs, as well as with 'mount -t smbfs' fails.
Samba used is one from RPM package at samba site (2.24 or 2.2.5 were 

smbmount called directly works all right,  backing down to mount 2.11b 
(keeping all other upgrades I made to move, partially, from RH7.1 to 
7.3) restores mount functionality.

Steps to Reproduce:
Setup: RH 7.1 with kernel and glibc (+ dependences) upgraded to RH7.3
mount-2.11n.  Samba-2.2.4 (rpm from samba site) serves share C on 
windows machine called ladybug.  Samba mount point /misc is NOT 
mentioned in fstab

1.   Run smbmount
# smbmount  //ladybug/C /misc
Password: xxxxxxxx
# mount
//ladybug/C on /misc type smbfs

2.  unmount
# umount   //ladybug/C
3.  Attempt mounting with mount fails
# mount -V
mount: mount-2.11n
# mount -t smbfs //ladybug/C  /misc
Password: xxxxxxx
execvp of smbmnt failed. Error was No such file or directory.smbmnt 
failed: 1

4.  Restore old RH7.1 mount package and try again
# rpm -U --oldpackage --nodeps mount-2.11b-3.i386.rpm
# mount -V
mount: mount-2.11b
# mount -t smbfs //ladybug/C  /misc
Password: xxxxxxxxxxx
# mount
//ladybug/C on /misc type smbfs (0)

5.  Check smbmnt for any case
# ls -l /usr/sbin/smbmnt
-rwxr-xr-x    1 root     root       453868 May  5 14:01 /usr/sbin/smbmnt


In the reply, RH people wrote that everything works with samba RPM from 
rawhide (2.2.4). This, I checked, is indeed the case.

More information about the samba mailing list