[Samba] brlock.tdb and locking.tdb always missing on RH 7.2

Richard Maclannan REM at dataconnection.com
Thu Jun 20 01:04:09 GMT 2002


I've been fighting with Samba for over a week now and I can't seem to work
it out. It all started when I installed the standard samba (2.2.1a-4) which
came with RH7.2.

I ran "smbstatus" and got the following error:

Failed to open byte range locking database
ERROR: Failed to initialise locking database
Can't initialise locking module - exiting.

I've tried the following to fix this:

- Added a "lock directory" parameter in my smb.conf file pointing to

- Created a blank STATUS..LCK file in /var/cache/samba

- Upgraded to 2.2.3 and 2.2.4 with the same error.

- Added various debug levels within smb.conf to get information on why this
is failing - all without success

I finally got some information by running "strace smbstatus". This told me
it couldn't find /var/cache/samba/brlock.tdb and
/var/cache/samba/locking.tdb. Bizarrely, these files don't seem to be
created *ever*, regardless of which version I use.

I got rid of the error messages by performing the most awful hack.

cp /var/cache/samba/messages.tdb /var/cache/samba/brlock.tdb
cp /var/cache/samba/messages.tdb /var/cache/samba/locking.tdb

This is clearly *wrong*. Then any shares I set up in my smb.conf file just
don't respond.

Basically, the question is: How do I get my brlock.tdb and locking.tdb files
to appear where they should? I think this will solve the whole problem.

Thanks in advance to anyone who considers this question.

Richard Maclannan

More information about the samba mailing list