[Samba] AIX / NT Networking

tony lay tonylay at hotmail.com
Wed Jun 5 12:22:03 GMT 2002

I'm running AIX 4.3.3MR9 on an H50 with NT4.0SP6a clients.
Samba is 2.2.4 compiled on the system with GCC.

I've been having an issue for a few weeks and it really looked like some 
type of name resolution issue.  When NT clients browse samba shares from my 
AIX server they take 30-60 seconds to come up.  Sometimes they won't come up 
at all.  All of my DNS, WINS, and hosts files check out and the network was 
up so I asked for some help snooping packts with our netadmin.  He was nice 
enough to visit and I tried to take the best notes I could so here goes...

I'm on the PDC trying to pull up a share from the SMBSERVER inside of the 
network neighborhood.  This runs for about a minute before kicking me out.

"no such file desktop.ini
account was null and the domain was null dest SMBSERVER -> source PDC
this disconnected .02 seconds later

pulled desktop.ini

ACK took too long to respond
insufficient buffer space on one side or the other?
(There are 2 of theses alerts)

WINS lookup
Tried to connect null again
tried to to connect PDC/IPC$
tried to pull netlogon -> SUCCESS
Lots of peramaters are passed
netrlogon call -> request challange
three way handshake
connects and disconnects.
NetBIOS traffic is detected, but cannon be encoded.
At the same time a "window frozen" error comes up.
NetBIOS session request -> confirmed
negotiation begins
Protocal Dialog index
account administrator PDC
WINS traffic
TCP traffic
NETBIOS 76 bytes of user data
confirms session
Negotiates anon
three way handshake and then closes down


I looked up all of the information I could on the windows frozen error as 
that was definately happening.  Didn't find too much on it besides a 
reccomendation that smbd & nmbd *NOT* be controlled by inetd.conf.  I 
removed them from the file and left swat and am still having trouble.

As far as the ACK error...the only information I could find was a protocol 
sheet on the main site.

Any help would be greatly appreciated,



Basically the samba server is a file server only.  No PDC BDC or WINS coming 
from it.  SECURITY=DOMAIN.  WINS is running on my PDC and a BDC.  Resolution 
in samba is WINS host (/etc/hosts has the whole network on the server).  
Passwords are encrypted, as they should be for NT...and are passed off to 
the PDC or BDC's.

I'm not too sure as to what's going on with the networking end of this and I 
could use some help.  Is there anything that is obviously wrong with that 
traffic?  Conf file included below:

	client code page = 437
	code page directory = /usr/local/lib/codepages
	workgroup = OURDOMAIN
	netbios name = SMBSERVER
	server string = Samba %v
	interfaces =
	security = DOMAIN
	encrypt passwords = Yes
	update encrypted = Yes
	password server = PDC BDC BDC2
	smb passwd file = /var/samba/private/smbpasswd
	passwd program = /bin/yppasswd
	username map = /usr/local/lib/users.map
	unix password sync = Yes
	log file = /var/samba/log/log.%m
	max log size = 50
	name resolve order = wins host bcast
	deadtime = 15
	max disk size = 7199
	socket options = TCP_NODELAY TCP_NODELAY SO_SNDBUF=32768 SO_RCVBUF=32768
	load printers = No
	logon path =
	logon home =
	local master = No
	domain master = False
	wins server =
	lock dir = /var/samba/locks
	pid directory = /var/samba/pid
	socket address =
	homedir map =
	admin users = Administrator, ntadmin
	create mask = 0755
	force create mode = 0755

	comment = Home Directories
	read only = No
	browseable = No

	path = /home/data
	read only = No
	inherit permissions = Yes

	comment = SOME DOCS
	path = /usr/catia/doc

Join the world’s largest e-mail service with MSN Hotmail. 

More information about the samba mailing list